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Using Data in Excel 
The following instructions are intended to provide some commonly used Excel functions, formulas, and 
procedures, and some information more specific to EI. Keep in mind that functionality may vary 
depending on the version, and that there are multiple approaches for accomplishing most tasks using 
Excel.  
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Formatting and File Structure 
 

Copy and paste all data into new worksheet 
In order to retain original data, it’s helpful to select the entire dataset and paste it into a new worksheet 
prior to altering the dataset in any way. To select all of the data, press “Ctrl” and “A” simultaneously. 
Press “Ctrl” and “C” to copy all of the data or Right Click and choose “Copy.” In a new sheet, select cell 
A1, then press “Ctrl” and “V” simultaneously to paste the previously copied data. 
 

 
 

Rename worksheet 
Naming each worksheet with a short description of what data are included helps quickly navigate 
through the file if it includes multiple tabs.  To do so, right click on the worksheet and click “Rename” or 
double click on the worksheet title, then type the desired name. 
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Make header row bold 
Click in the pane to the left of the row (labeled 1, 2, 3…) to highlight the entire row.  Then navigate to 
the “Home” tab and click on the “B.” 
 

 
 

 
 

Edit font 
Press “Ctrl” and “A” simultaneously to highlight the entire worksheet or click in a cell and drag the 
mouse to highlight specific cells . Navigate to the “Home” tab toward the left of the Excel ribbon. Select 
desired font from the drop down in the Font area. 
 

 
 

General cell formatting 
In addition to selecting desired font, there are many different options for structuring cells that can 
distinguish them, make them easier to read, or ensure they are in the needed format. To format cells, 
highlight the area where formatting changes are needed.  Right click within the highlighted area and 
choose “Format Cells.”  Use the tabs to format cells as desired. 
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Add or Remove Wrap Text 
“Wrap Text” is a formatting function that adjusts the height of the row in order to ensure all text within 
the cell is visible. Depending on the desired layout of the worksheet, it can be helpful to turn the wrap 
text feature on or off. To do so, select desired cells or area.  Select or unselect the “Wrap Text” option in 
the Alignment section on the “Home” tab. 
 

 
 

Adjust column width 
If a series of pound signs (#####) is all that’s visible in a cell, the column width needs to be adjusted in 
order to view the data in the cell.  Adjusting column width may allow for better visibility of certain cells, 
in general, as well.  Within the pane above the top cell (labeled A,B,C…), click on the line to the right of 
the row for which width needs to be adjusted. The cursor will turn into a line with arrows on both sides. 
Drag the mouse until the column is the desired width. 
 

 
 
Using filters 
To utilize filters, first highlight the top row of the file that includes the field names.  To do so, click on the 
“1” to the left of the first column in the dataset. The green outline around the cells indicates the row is 
selected. 
 

 
 
Navigate to the “Data” tab of the Excel ribbon in the Sort & Filter section and select “Filter” to turn 
filters on.  Click the downward facing triangle in any cell to select information to filter (examples are 
included subsequently).   
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The filter feature can also be used to sort information in a particular order.  To sort by a specific field, 
navigate to the desired field and click on the filter button. Select the desired filter order (e.g., 
chronological, alphabetical, etc.), then press “OK.” 
 

                
 

Remove extra information (delete rows) using filters 
Removing extra data from a working file can make navigating the dataset simpler and more 
straightforward. To do so, ensure filters are turned on in the top row.  Navigate to the desired column, 
click on the filter button, and select all of the information that needs to be removed.  Highlight all of the 
selected rows by clicking in the numbered columns to the left and dragging the mouse down to select all 
visible rows.  Right click anywhere in the selected area and click “Delete Row.”  Turn filters off to view 
the remaining data. 
 
Alternatively, use filters to select all desired information.  Copy all selected data and paste into a new 
tab. 
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Hide columns 
Hiding columns allows a user to temporarily remove entire columns from view. This is a great way to 
make a dataset more manageable without actually deleting any data. To do so, highlight desired 
columns using the pane above the top cell (labeled A,B,C…).  Right click in highlighted area and select 
“Hide.” 
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Freeze Panes 
Freezing panes allows the user to keep certain cells visible at all times.  This is particularly helpful to 
always be able to view header rows and child names and/or ETIDs. Select the cell below and to the right 
of the row(s) and column(s) that need to always remain visible. 
 

 
 

Navigate to the “View” tab on the Excel ribbon and select “Freeze Panes.”  Click “Freeze Panes” from the 
drop down. 
 

 
 

 
Common EI Calculations 
Formulas in Excel are a very useful way to calculate values.  Several pre-defined formulas, called 
functions, are available in Excel.  In addition to the readily available functions, many other formulas can 
be used to make calculations.  Formulas include the following components: 

 Equals sign (=): Each formula begins with an equals sign and is followed by one or more of the 
subsequent components 

 Cell references: Many times, formulas include references to a particular cell, defined by the 
column letter and row number (e.g., A1) 

 Operators: These are the components that specify the type of calculation that should be 
performed  

 Constants: Some formulas contain text or numbers in addition to or instead of cell references 
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See the information that follows for instructions regarding how to make calculations for data commonly 
used in EI. 
 

 
 

Third Birthday 
The ‘EDATE’ formula calculates a date that is the specified number of months from the date in the 
referenced cell. Because children can be served in EI until age three, calculating the third birthday is 
useful in a lot of circumstances for cleaning data or making calculations.  Right click the “Child Due Date” 
column in the pane above the top cell (labeled A,B,C…). Select “Insert” to add a new column to the right 
of the “Child Birth Date” column and add a column name. 

 
 
Click in the top cell of the new column, then type the formula “=EDATE(E2,36)” and press enter. In this 
example, “E2” was referenced (Column E, Row 2), as that was the cell where the child’s birth date was 
located, so this formula may need to be adjusted to reference the proper cell. “36” was used to 
calculate the date that is 36 months from the child’s birthday, or the child’s third birthday - that number 
can also be adjusted as needed to make different calculations. 
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Initial IFSP Date 
If a data file includes multiple IFSPs for the same child, it can be helpful to calculate the initial IFSP.  In 
doing so, it is important to ensure the dataset includes all IFSPs within the referral period for the child.  
To make this calculation, first sort by the IFSP date (Oldest to Newest), then sort by ETID.  Insert a new 
column and utilize the following formula to identify the initial IFSP: =IF(AND(B2=B1,K2=K1),N1,M2) 
where B2 and B1 reference the ETID, K2 and K1 the referral date, N1 the initial IFSP date being 
calculated, and M1 the IFSP date, as shown in the screenshot below. 
 

 
 

Due Dates 
Due dates can be calculated for required components of EI by using addition or subtraction formulas.  

For example, to calculate when 45-day timelines expire, add 45 to the referral date (=D2+45 where D2 

references the referral date, as shown in the screenshot below). 

 
 
To calculate the date by which a service is due to start to meet the Timely Receipt of Services (TRS) 

requirement, add 30 days to the IFSP Added Date, which can be found on the EI Services Report 

(=T2+30, where T2 references the date the service was added to the IFSP).   

 
 
To calculate TPC due dates, first calculate the third birthday as described above.  Then subtract 90 from 
the calculated third birthday (=F2-90, where F2 references the child’s third birthday). 
 

 
 
Formulas can also be used to calculate the amount of time between two dates in a file.  For example, 

subtract the IFSP Added Date from the Service Start Date to calculate the number of days between the 

date the service was added to the IFSP and the first time the service was delivered (=X2-V2, where X2 is 

the service start date and V2 is the date the service was added to the IFSP). 
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Functions that are useful when utilizing formulas 
 
Autofill column to apply formula to all rows 
When the same information (number, formula, etc.) needs to be included in every cell within a column, 
the autofill function is very helpful. For example, when calculating the third birthday for every child, the 
formula can be copied into each cell within the column to the end of the data file.  First, make sure there 
are no filters selected.  Then navigate to the bottom right corner of the cell that contains the formula 
you intend to copy. A cross will be displayed in place of the typical pointer. Double click in this location, 
and the formula will be copied into each cell in the column. 
 

 
 

Copy and Paste Special 
The ‘Paste Special’ function is useful for selecting a group of information and pasting it all into a 
different format.  For example, when utilizing formulas, the values that result from the formulas can be 
copied and pasted to retain the values when performing other functions, such as sorting, filtering, or 
deleting columns, in the data file.  To do so, select the entire column by clicking on the column letter 
above the header row.  Press “Ctrl” and “C” simultaneously to copy the data. Right click in the first row 
of the column and select the second paste option with the “123” at the bottom of the clipboard image. 
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Pivot Tables 
 
PivotTables are an extremely useful tool in Excel that can be used relatively easily to analyze and 
organize, and ultimately to share, a broad array of data.  To create a pivot table, navigate to the “Insert” 
tab, then click on “PivotTable.” 
 

 
 
By default, the Table/Range should include all cells within the worksheet and will populate in a new 
worksheet.  Ensure the selected options are appropriate, then click “OK” to create a blank PivotTable 
table in a new sheet. 
 
Note: If the Table/Range does not default to the entire worksheet, check to ensure there are no 
completely blank columns, and select only one cell that has data in it prior to creating the pivot table.  
 

 
 
A new worksheet will appear to the left of worksheet from which the data were selected. A blank 
PivotTable will appear on the left side of the new worksheet, and the available PivotTable fields along 
with options for columns, rows, filters, and values will appear on the right. 
                     



 

 
Ohio Department of Developmental Disabilities  Page 13 of 14 
Using Data in Excel  Revised 4/17/19 

                                 
 
Drag fields to the desired location (FILTERS, COLUMNS, ROWS, and/or VALUES) to create a customized 
table with the desired information.   
 
To show values of zero, click anywhere within the table.  Navigate to the “ANALYZE” tab. Click on 
“Options” and select “Options” from the drop down. 
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In the PivotTable options pop-up, within the “Layout & Formula” tab, enter “0” in the “For empty cells 
show:” box.  Then click “OK.” 
 

 
 
 

Need Additional Resources or Assistance? 
See the individual report “instructions and tips” documents for examples of how to use specific EI report 

data.  If you have any questions regarding how to obtain needed information from any report, email 

eids@dodd.ohio.gov at any time. 

mailto:eids@dodd.ohio.gov

